Exploit f├╝r Firefox aufgetaucht

F├╝r einen Fehler in der Funktion QueryInterface von Firefox in der Version 1.5 ist ein Exploit aufgetaucht. Speziell pr├Ąparierte Webseiten k├Ânnen der alten Version von Firefox so beliebigen Code unterschieben, der dann auf dem System ausgef├╝hrt wird.

Bisher steht der Exploit nur f├╝r Firefox Versionen unter Mac OS X und Linux bereit. Es d├╝rfte wohl aber nicht mehr lange dauern, bis auch Windows Versionen davon betroffen sind.

Da das Leck in der aktuellen Version 1.5.0.1 bereits behoben wurde, ist ein Update dringend angeraten und wird mittlerweile sogar als kritisch angesehen.

Speicherproblem mit Firefox 1.5.0.1 immer noch vorhanden

Folgende Korrekturen finden sich laut http://www.mozilla.com/firefox/ in der aktuellen Version von Firefox:

Here’s what’s new in Firefox 1.5.0.1:

  • Improved stability.
  • Improved support for Mac OS X.
  • International Domain Name support for Iceland (.is) is now enabled.
  • Fixes for several memory leaks.
  • Several security enhancements.

Leider kann ich bisher die Korrektur der „Memory leaks“ nicht best├Ątigen. Im Gegenteil: seit der Aktualisierung ist das Problem noch viel schlimmer geworden. Read More Speicherproblem mit Firefox 1.5.0.1 immer noch vorhanden

WordPress aktualisiert auf Version 2.0.1

Endlich bin ich dazu gekommen WordPress auf die aktuellste Version zu aktualisieren. WordPress 2.0.1 ist ein Bugfix Release. Insgesamt wurden 114 Fehler behoben. Eine genaue Liste findet sich hier.

Unter http://blog.wordpress.de findet sich eine genaue Anleitung zum Aktualisieren der Software. Blogger, die eine neue Version installieren, finden hier die ausf├╝hrliche Anleitung zur Neuinstallation.