Installation von punBB

Hintergrund
Vor einiger Zeit habe ich mich dazu entschieden für unsere World of Warcraft Gilde „Die Weltenwanderer“ ein neues Forum zu verwenden. Bisher lief das phpBB Forum. Leider habe ich es trotz mehrfachen Versuchen weder hinbekommen Moderatoren zu bestimmen noch unterschiedliche Gruppen anzulegen und mit den entsprechenden Rechten auszustatten. Vermutlich lag das an dem installierten Theme.

Aufgrund eines Tipps von einem Bekannten, habe ich mal punBB in der aktuellen Version 1.2.10 versucht.

Voraussetzungen zur Installation von punBB

Der download ist mit seinen 259KB nur 1/3 so groß wie der download des phpBB Forums mit seinen 799KB. Mal schauen ob die Funktionalität trotzdem meinen Erwartungen entspricht.

Nach dem Entpacken finden sich verschiedene Verzeichnisse in dem Extrakt:

  • docs (beinhaltet Installationshinweise, Tipps für Entwickler und einige Links zu den wichtigen Seiten)
  • extras (Update Script von Version 1.2 nach 1.2.10 und eine Beispiel-Configdatei)
  • upload (Dieses Verzeichnis beinhaltet alle Dateien, die zum Betrieb des Forums nötig sind)

Also das Upload Verzeichnis hochgeladen und die URL aufgerufen. Hier erfolgte ein Hinweis, das noch keine Config-Datei vorhanden sei und man erst den Installer aufrufen solle.

Der Installer
Folgende Angaben benötigt der Installer um die Installation auszuführen:

  • Datenbank Typ
  • Datenbank Server Hostname
  • Der Datenbankname (Wird auch angelegt, wenn notwendig)
  • Ein Username und das zugehörige Passwort
  • Ein Prefix, der den einzelnen Tabellen vorangestellt wird

Zusätzlich dazu kann direkt ein Administrator angelegt werden. Hierfür trägt man einen Usernamen, das Passwort und eine E-Mail Adresse ein. Als letzten Wert, verlangt das Forum die URL zu dem selben. Während der Installation hat es bei mir die URL nicht korrekt erkannt, so das ich sie noch mal eingeben musste. Dabei sollte der abschließende Slash (/) nicht angegeben werden.

Nach dem Starten der Installation erschien ein abschließender Hinweis. In einer Textarea wurde der Inhalt für eine Datei angezeigt, den man speichern und als config.php im Rootverzeichnis des Forums ablegen sollte. Damit sollte die Installation abgeschlossen sein.

Und tatsächlich: ein jungfräuliches Forum erblickte das Licht der Welt 😉

1 Kommentar

  1. tredinertok

    Hello

    Very interesting information! Thanks!

    Bye

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.